View Issue Details

IDProjectCategoryView StatusLast Update
0013522phplist applicationHTML Email Supportpublic29-04-11 14:15
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.10.13Fixed in Version2.10.14 
Summary0013522: "powered by phplist" line in emails causes CSS style dump in Eudora for Mac
Descriptiontripper54 suggests this fix in http://forums.phplist.com/viewtopic.php?p=25067#25067

****START QUOTE****
I'm setting up a list for a company here in Sydney. Unfortunately, the CEO uses Eudora for Mac, which, as we all know, has no support for CSS. This meant the "powered by phplist" line at the bottom of the email was preceded in his nasty email client by a dump of the contents of the associated <style> tag.

I was able to fix this using the old trick of adding comment markup to relevant php in connect.php. My altered code follows (between the dashes):

---------------------------------------

$PoweredByText = '
<style type="text/css"><!--
.poweredphplist {font-family: arial, verdana, sans-serif;font-size : 10px; font-variant: small-caps; font-weight : normal; padding: 2px; padding-left:20px;}
a:link.poweredphplist,
a:active.poweredphplist,
a:visited.poweredphplist {font-family: Arial, verdana, sans-serif; font-size : 10px; font-variant: small-caps; font-weight : normal; color : #666666; text-align : center; text-decoration : none; padding: 2px;}
a:hover.poweredphplist {color : #7D7B7B;}
//--></style>
<span class="poweredphplist">powered by http://www.phplist.com v '.$v.', © http://tincan.co.uk/powered</span>';


---------------------------------------------

Perhaps this should be rolled into the next version?

****END QUOTE****
TagsNo tags attached.

Activities

h2b2

29-02-08 08:25

manager   ~0041878

On a related note tjmb suggests this in http://forums.phplist.com/viewtopic.php?p=37795#37795

****START QUOTE****

Since Webmail services such as Gmail, Yahoo, and Hotmail tend to strip out or disable <style> elements in HTML e-mail, it might be worth considering changing the poweredphplist code entirely to something like:

Code:
<div style="clear: both; font-family: arial, verdana, sans-serif; font-size: 10px; font-variant: small-caps; font-weight: normal; padding: 2px; padding-left:20px;">powered by http://www.phplist.com v 2.10.4, © http://tincan.co.uk/powered</div>


This will help prevent the Powered By div from ending up in an odd position within the mailing, and will help to ensure that most of the styling stays intact.

For details about what Gmail, Yahoo, et. al. do when rendering HTML email, see http://www.xavierfrenette.com/articles/css-support-in-webmail/

****END QUOTE****

michiel

29-04-11 14:14

manager   ~0051202

done as suggested in 0013522:0041878 (thanks!)

Issue History

Date Modified Username Field Change
29-02-08 08:23 h2b2 New Issue
29-02-08 08:25 h2b2 Note Added: 0041878
17-03-08 17:29 user1822 Target Version => 2.10.6
17-03-08 17:29 user1822 Description Updated
29-04-10 04:55 h2b2 Target Version 2.10.7 => 2.10.13
29-04-11 14:14 michiel Note Added: 0051202
29-04-11 14:14 michiel Status new => resolved
29-04-11 14:14 michiel Fixed in Version => 2.10.14
29-04-11 14:14 michiel Resolution open => fixed