View Issue Details

IDProjectCategoryView StatusLast Update
0012800phpList 3 applicationBrowser Issuespublic06-08-18 13:35
Reporterjsherk Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.10.5 
Fixed in Version2.10.9 
Summary0012800: When Display Confirm Email is selected and field is left blank, the javascript message does not display correctly.
DescriptionSee this thread:
http://forums.phplist.com/viewtopic.php?p=40685


Found this bug in 2.10.5

To reproduce this bug:
(1) Go to Edit one of your Subscribe Pages, choose Display Email Confirmation, and save changes.
(2) Go to this particular subscribe page in your browser, and enter anything into the Email field, but leave the Confirm Email field BLANK.
(3) Click the submit/subscribe button, and you will get a message that says something like "Please enter your", but it doesn't tell you what to enter.


PROBLEM:
In the admin/subscribelib2.php file, on line 702, it reads as follows:

$GLOBALS["strConfirmEmail"],htmlspecialchars(stripslashes($_REQUEST["emailconfirm"])),$textlinewidth, $GLOBALS["$strConfirmEmail"]);

The problem is that the second $GLOBALS contains $strConfirmEmail with a $ in front of it. There should be no $ in front of strConfirmEmail.


FIX:
Remove the $ from in front of strConfirmEmail so line reads as follows:

$GLOBALS["strConfirmEmail"],htmlspecialchars(stripslashes($_REQUEST["emailconfirm"])),$textlinewidth, $GLOBALS["strConfirmEmail"]);

TagsNo tags attached.

Relationships

duplicate of 0015192 resolveduser4377 Confirm Email Alert with no fieldname when Empty 

Activities

michiel

18-12-08 17:33

administrator   ~0050271

this sounds like a duplicate, but can you check Claudio?

user4377

08-01-09 18:47

  ~0050277

The fix was done.

Thanks for the contribution.