View Issue Details

IDProjectCategoryView StatusLast Update
0012626phplist applicationConfigurationpublic09-08-11 11:58
Reporterrecklessgeneral 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.4 
Target Version2.10.XFixed in Version2.10.14 
Summary0012626: Slashes not stripped from custom subscribe message
DescriptionI have changed the default subscribe/unsubscribe messages and noticed during testing that some of the messages emailed during subscription/confirmation process contain backslashes before quotes etc. Having a quick skim through the code it looks like stripslashes() is being inconsistently applied to the custom messages retrieved from the database, so for example the unsubscribe message is backslash-free but the subscribe message sent from importcsv.php (requesting confirmation from imported users) and the confirmation message itself contain backslashes.

My magic quote settings are as phplist recommends (this was one of the first things I checked)
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
related to 0002305 resolvedmichiel basckslashes in unsubscribe mail 

Activities

michiel

29-04-11 13:28

manager   ~0051201


I found the one on sending the request for confirmation on import, but I couldn't replicate any others (like confirmation message).

http://phplist.svn.sourceforge.net/phplist/?rev=2667&view=rev

if you find more of them, let me know.