View Issue Details

IDProjectCategoryView StatusLast Update
0011976phpList 3 applicationCampaign Send Processpublic23-05-12 16:01
Reportermichiel 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.10.5 
Target VersionFixed in Version 
Summary0011976: detect process queue looping and cut if off
Description
sometimes processqueue fails on one or two emails and keeps retrying forever. The new email validation should catch that, but just in case, it could be useful to detect the process looping and put a limit on it, eg try 10 times and then consider it sent.
TagsNo tags attached.

Relationships

duplicate of 0013672 new how often to retry sending to an address that fails, and give up 
related to 0002705 closed PHPList v2.11 release 
related to 0010174 resolvedmichiel Processqueue gets stuck in infinite loop with concatenated email addresses 

Activities

h2b2

03-04-08 00:42

manager   ~0044082

Seems related to this report: http://mantis.phplist.com/view.php?id=10174

gazouteast

08-10-10 15:03

reporter   ~0051123

.

First reported THREE YEARS AGO this month

Has anything been done to fix it?
I don't consider this a minor issue - stunts like this get hosting accounts suspended and sites taken off line - this relates to business sustainability and people's livlihoods. This should at least have "major" status.

.