View Issue Details

IDProjectCategoryView StatusLast Update
0011959phpList 3 applicationAdmin Managementpublic22-05-12 16:19
ReporterADobkin 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.10.5 
Target VersionFixed in Version 
Summary0011959: Missing TLD for .travel domains
DescriptionWe recently sent out a travel-related newsletter using PHPList. Some of our subscribers have e-mail addresses in the .travel domain, which has been a valid TLD since 2005:

http://en.wikipedia.org/wiki/.travel

When processing the queue, these recipients are flagged as "invalid emails", and no delivery attempt is possible within PHPList. In order to solve the problem, I had to edit admin/commonlib/lib/userlib.php and add "travel" to $pattern. Then I had to remove and re-add the affected subscribers so PHPList would send the message to them on a requeue. Please make this change in the source for future release.
TagsNo tags attached.

Relationships

duplicate of 0015632 resolvedmichiel TLDs missing from is_email() validation 
related to 0002705 closed PHPList v2.11 release 

Activities

h2b2

04-01-10 05:48

manager   ~0050810

New TLD's that could be added are mentioned in this and subsequent forum post: http://forums.phplist.com/viewtopic.php?p=70185#p70185

gazouteast

02-10-10 19:49

reporter   ~0051111

'

Was any update of the valid tld list done for 2.10.10 or 2.10.12 ?

Seems to me to be amongst the easier fixes that could have been completed for a bug fix release.

.