View Issue Details

IDProjectCategoryView StatusLast Update
0011231phplist applicationSubscribe Processpublic12-05-11 19:15
ReporterRationalRabbit 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.4 
Target Version2.10.XFixed in Version2.10.13 
Summary0011231: Hard return truncating data in textarea
DescriptionI noticed that someone posted this problem over a year ago and never got a reply. Someone sent me here, where I found one report, but I don't think the issue was understood. This is not just truncating a message in the e-mail sent, it is truncating it before it is entered in the database. I have looked at the database, and the messages are truncated there as well.

When a hard return is used in an attribute textarea, the remaining data is truncated.
The user is totally unaware their text is not all making it to its intended destination.
Additional InformationLinux (CentOS)
2.6.9-023stab043.1-enterprise
Apache 1.3.37 (Unix)
PHP 4.4.7
MySQL 4.1.22-standard
URL: http://www.shadle67.com/maillist/?p=subscribe
TagsNo tags attached.

Relationships

related to 0005880 closedmichiel using a textarea attribute value in a message doesn't output all the data 

Activities

h2b2

02-09-07 15:47

manager   ~0031506

Possibly related to: http://mantis.phplist.com/view.php?id=5880

Ref: http://forums.phplist.com/viewtopic.php?t=11533

michiel

12-05-11 19:15

manager   ~0051330

seems ok in the demo, which still runs 2.10.13:

http://demo.phplist.com/lists/admin/?page=user&start=0&id=15&find=test&sortby=0&sortorder=desc&unconfirmed=0&blacklisted=0

I'll upload a screenshot, in case the demo resets itself (can't remember, I think it does)

michiel

12-05-11 19:15

manager  

bug11231.png (17,702 bytes)
bug11231.png (17,702 bytes)