View Issue Details

IDProjectCategoryView StatusLast Update
0001113phpList 3 applicationHTML Email Supportpublic20-05-05 03:39
Reporterpdbrett 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0001113: Spurious
tags inserted using FCKeditor
DescriptionUsing PHPlist 2.8.3, if I compose a message using FCKeditor and it looks OK then send it immediately everything’s fine.

If however I save the message as a draft then visit other PHPlist pages or logout and then come back to edit the message, the message loads into FCKeditor with lots of white space that wasn’t there before. If I click on the “source” box in the top left corner I can then see that somehow a load of
tags have been added to the source in inappropriate places.

For example, if the beginning of the HTML code looks like this before saving:

<TABLE width=600 border=0>
<TBODY>
<TR>
<TD>
etc.

It looks like this after saving, exiting and coming back to edit:

<TABLE width=600 border=0>

<TBODY>

<TR>

<TD>

etc.

I looked in the "message" table of the database and saw that the source is saved correctly there. So the problem must be something to do with the message being reloaded from the database into FCKeditor for editing.

You can strip the
tags out manually but that is far from ideal!

This happens on a number of different PHPlist systems including the demo account on phplist.com.
TagsNo tags attached.

Activities

pdbrett

31-03-04 10:59

reporter   ~0001144

Last edited: 31-03-04 11:00

Oops, it needs to say BR tags - I will try to escape them like this: \<BR\>.

the source example should have read:

<TABLE width=600 border=0>\<BR\>
<TBODY>\<BR\>
<TR>\<BR\>
<TD>\<BR\>

escaping didn't work, oh well, hopefully you'll get the idea...

edited on: 03-31 11:00

michiel

02-04-04 23:53

manager   ~0001156

These are very hard to me to debug as I don't really have the development environment for this. Once I'm on two machines again (a win and a lin) I'll try to check it out. If you find anything in the meantime that would be great.

pdbrett

13-04-04 17:15

reporter   ~0001206

This started happening again even with the changes to fck_config.js:

config.UseBROnCarriageReturn = false ;


So I did some rooting around and found the following lines in send_core.php:

    if ($usefck) {
    $_POST["message"] = nl2br($_POST["message"]);
    }

when I commented them out, voila! it now works - hope this helps....

michiel

13-04-04 17:19

manager   ~0001207

ah, that's very useful thanks. The odd thing is that when I test it, it only seems to do it with tables, and not with the rest, so I suspect it also has to do with tables getting an extra \n. I'll check that.

pdbrett

16-04-04 11:24

reporter   ~0001213

Well, my messages are mostly made up of tables at present (a shame that more email clients aren't more XHTML/CSS compliant) so that's mostly where I noticed it.

However, it also happened when I had some styles defined in the header, like so:

<STYLE type=text/css>
\<br /\>
\<br /\>
\<br /\>
\<br /\>
<!--
body { font-family: Arial; font-size: 12px; }
\<br /\>
h3 { font-family:Arial, Helvetica, sans-serif; font-size:16px; color:#000; font-weight:normal; padding-left:4px; display:inline; }
\<br /\>
.
.
etc.

Commenting out the nl2br() call also worked in this case.