View Issue Details

IDProjectCategoryView StatusLast Update
0011011phpList 3 applicationSubscribe Processpublic09-06-19 23:11
Reportersubnoodle 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version2.10.4 
Target Version3.4.3Fixed in Version 
Summary0011011: Preselection of one, all or some lists per subscribe-page url
DescriptionHad the problem that i just had one subscribe page for all (6) lists.
Depending on from were a user comes to the subscribe page, it should be only one or more lists preselected in the subscriber page.

So i decided that i have to call the subscriber page url with a additional parameter 'preselected', using it with comma seperated values of list-ids.

Additional InformationCodesnipet in
phplist-2.10.4/html/lists/admin/subscribelib2.php
Line 611 changing to

if ( (isset($list[$row["id"]]) && $list[$row['id']] == "signup") ||(isset($_REQUEST["preselected"]) && (in_array($row['id'],explode(",",$_REQUEST["preselected"])))))


enables this.


TagsNo tags attached.

Relationships

related to 0015235 resolved Support setting list membership and HTML preference via HTTP GET vars for remote subscriptions / ajax / form submissions 

Activities

subnoodle

11-08-07 00:10

reporter   ~0030378

Can you make this permanent, please in next releases?
Thanks!
Sam

user4402

16-02-09 13:57

  ~0050500

Closing issue because it is too old. If you feel it is still relevant please add again and give the new context. Thanks!

lwc

08-06-19 12:56

updater   ~0062333

I believe #15235 fixed this issue, so please close.