View Issue Details

IDProjectCategoryView StatusLast Update
0010174phpList 3 applicationBatch Processingpublic23-05-12 16:00
Reporterbtoland 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.10.4 
Target VersionFixed in Version 
Summary0010174: Processqueue gets stuck in infinite loop with concatenated email addresses
DescriptionI found that the processqueue will get stuck in an infinite loop if two email address get concatenated accidentally. That is, it keeps trying to send over and over and over to that one address but keeps failing because it's a bad address.

Email format like this: "user1@domain1.com;user2@domain2.com" will be imported and NOT flagged as invalid and "reconcile users" does not pick it up.

Of course the ISP fails it because it's invalid, but processqueue keeps trying to send it every batch time.

Can you folks add a check in the import function to guard against two @ signs?

This is a problem because as process queue gets stuck in an infinite loop I cannot tell if the mails have been successfully sent...
TagsNo tags attached.

Relationships

duplicate of 0013672 new how often to retry sending to an address that fails, and give up 
related to 0002705 closed PHPList v2.11 release 
related to 0014970 resolvedmichiel "Duplicate" emails selected but not counted in total sent. Message remains "inprocess". 
related to 0011976 resolvedmichiel detect process queue looping and cut if off 

Activities

btoland

03-06-07 14:58

reporter   ~0027497

OK, I've tested this with some test lists and all the people apart from those with a concatenated email receive the message fine so this is really a just a minor issue not a major one. Just have to leave the process queue page after I think all messages sent....

Still annoying as I get multiple report messages delivered too - one each loop.

h2b2

03-04-08 00:45

manager   ~0044083

Seems related to http://mantis.phplist.com/view.php?id=11976


Similar issues have also been reported in these forum threads:
 http://forums.phplist.com/viewtopic.php?t=10087
 http://forums.phplist.com/viewtopic.php?t=13077
 http://forums.phplist.com/viewtopic.php?t=17408

g4b0

28-04-08 11:20

reporter   ~0045914

I've noted the same behavior when the email is valid, but it does not exist. I tested it using an email in my domain like noemail@domain.it

Same behavior.

h2b2

03-05-11 17:15

manager   ~0051259

This issue has also been reported for recent releases, including 2.10.12/13.
In this forum post, thisisit3 suggests a minor code change as a (temporary) fix: http://forums.phplist.com/viewtopic.php?p=31375#p31375