View Issue Details

IDProjectCategoryView StatusLast Update
0010051phplist applicationBatch Processingpublic29-04-11 16:16
Reporterbhugh 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.13Fixed in Version2.10.14 
Summary0010051: rss threshold comparison should be >=, not >
DescriptionThis line in processqueue.php is currently:
            $cansend = sizeof($rssitems) && (sizeof($rssitems) > $rss_content_treshold);

Should be:
            $cansend = sizeof($rssitems) && (sizeof($rssitems) >= $rss_content_treshold);

The reason: the config page says the threshold is "Minimum amount of items to send in an RSS feed", thus >= matches this statement.
TagsNo tags attached.

Activities

user4402

16-02-09 13:33

  ~0050493

Closing issue because it is too old. If you feel it is still relevant please add again and give the new context. Thanks!

h2b2

02-06-10 01:33

manager   ~0051030

Last edited: 02-06-10 01:50

Re-opened for review. This issue may still be relevant in v2.10.12.

See: http://forums.phplist.com/viewtopic.php?p=76184#p76184

gazouteast

27-09-10 10:44

reporter   ~0051099

.

+1 for this - it IS still relevant in 2.10.12

Gaz

.

michiel

29-04-11 16:16

manager   ~0051209

http://phplist.svn.sourceforge.net/phplist/?rev=2674&view=rev